The Norfolk BroadsThe Norfolk Broads
Username Password
Norfolk Broads Weather

Mon, 11 Apr 2016 7:20 am BST- Light Rain
5 Day Forecast

Wind 2.0 mph @ 40°
48.0°F/8.89°C Humidity 93% Pressure 29.65 (S)

Welcome to The Norfolk Broads Forum
This is THE Worlds Largest Forum devoted to the Norfolk Broads, here you can discuss issues about the Norfolk Broads. Or just somewhere to chat with others interested in the Norfolk Broads area. In 2015 forum members spent 2,048 days afloat on the Broads

Please Help Support The Norfolk Broads Forum
OR

The Norfolk Broads Forum / Broads Boat Owners Q & A / valor vanette3
login
join
Graphics Off
Search
Forum Members - Book your Hoseasons holiday today, Just call 0345 498 6296

This is a moderated forum Reply to this DiscussionReply to Discussion | Start new discussionNew Discussion << previous || next >> 
Posted By Discussion Topic: valor vanette3

book mark this topic Printer-friendly Version  send this discussion to a friend  new posts last

ADI
May-10-2018 @ 11:28 PM                           Permalink
reply
edit
profile
send p.m.
Been Posting For a Long Time
Posts: 1935
Joined: Oct 2009
ADI
          

Add To Ignore List
hi our oven isn't working this season, we light the gas as normal but after 10-20 seconds the flame doesn't increase to heat the oven as it did last year, it looks like there is a sensor just above the burner in the flame and another one located in the top of the oven leading to the oven control knob, can anyone advise what the problem could be please?

Regards

Adrian  Michelle

Beck  Braydon and Mere.


Attached File
View Full Size Image

Davidpettitt
May-11-2018 @ 6:33 AM                           Permalink
reply
edit
profile
send p.m.
Broads Minded
Posts: 43
Joined: May 2016
          

Add To Ignore List
I would check the gas nozzle first make sure it's not blocked. had the same problem with my cooker last year .took the nozzle out clean it work a treat after that

spiderman
May-11-2018 @ 7:26 AM                           Permalink
reply
edit
profile
send p.m.
Forum Regular
Posts: 458
Joined: Sep 2013
          

Add To Ignore List
Do you need any tips for removing melted plastic off the burners  LOL

Sorry couldn't resist it!  Exterminate

Steve51
May-11-2018 @ 7:50 AM                           Permalink
reply
edit
profile
send p.m.
Mardles sometimes
Posts: 3286
Joined: Dec 2006
Steve51
          

Add To Ignore List
The sensor in the flame is the thermocouple, which when heated, keeps the gas valve open allowing the flame to remain alight. The other sensor is the regulo which controls the flame height according to the setting on the control knob. The most likely cause of the problem would appear to be a faulty regulo control.

Steve. CM1 and NR12

Regulo
May-11-2018 @ 8:00 AM                           Permalink
reply
edit
profile
send p.m.
Mardles sometimes
Posts: 2602
Joined: Jun 2008
Regulo
          

Add To Ignore List
"The most likely cause of the problem would appear to be a faulty regulo control."

Nothing to do with me, pal!  Wink

Regards, Ray.

Whatever happens now, I'm blaming it on Brexit. Everyone else is!


Home Photo Gallery Days Afloat Contact Us
Chat Room Downloads Norfolk Broads @ Amazon Make My Logo
Shops & Businesses Members Gear Norfolk Broads @ EBay Holiday Calendar
Pub Guide Tide Tables SOS List Popular Threads
2017 Calendar Contest Make A Donation Links Hireboat Info
Norfolk Broads @ CafePress FAQ Broads Quiz Forum Events
Advertise With Us Forum Shop Boating Bits Stickys and FAQs Boating Bits Hirecraft List

 

 

 



Copyright © 2005 Y2KInternet, All Rights Reserved.